Weather Portlet
  1. Weather Portlet
  2. WPT-61

Change ehcache from annotations to explicit cache handling

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 1.0.10
    • Component/s: None
    • Labels:

      Description

      Some users are experiencing issues where despite having a connection timeout and timeout set, a socket will be hung up at socket.connect or socket.read. The problem is that the ehcache annotations wrap the cache with a blocking cache. This causes all future threads for the same cache key to be blocked, causing threads to hang (cascading effect) eventually causing the portlet to not execute ANY email preview portlet threads due to too many hung worker threads.

      Remove the cache annotations and instead calculate the key and manage the cache similar to the way the CalendarPortlet does using a non-blocking cache so you don't get a cascading effect of one thread causing multiple future threads (probably the same user logging on another time) to cause subsequent threads to block and hang.

      See attached stack trace and related linked issues.

        Issue Links

          Activity


            People

            • Assignee:
              James Wennmacher
              Reporter:
              James Wennmacher
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: