Weather Portlet
  1. Weather Portlet
  2. WPT-56

Add/remove location does not refresh view

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Cannot Reproduce
    • Affects Version/s: 1.0.8, 1.0.9
    • Fix Version/s: None
    • Component/s: None
    • Labels:
      None
    • Environment:
      uP 3.2.4 and uP3.2.5
      Linux Redhat
      Browsers: IE, Firefox, Chrome, Safari

      Description

      When I delete a location in our Linux dev environment, the list does not refresh after clicking the “X” to delete, but when I click the “Done” button, it returns to Normal view without the deleted city showing. In my Windows PC environment, the deleted city will disappear from the list, as expected, when the "X" icon is clicked. It behaves the same in IE, Firefox, Chrome and Safari.

      Using DEBUG logging, I have been able to find differences between the two environments. In the PC environment, the AjaxServlet is invoked after clicking the “X”, but in the linux environment, none of the DEBUG statements below appear in the log.

      Delete City - PC only
      ---------------------
      DEBUG [http-8443-6] servlet.DispatcherServlet.[] Sep/18 09:28:27 - DispatcherServlet with name 'AjaxServlet' determining Last-Modified value for [/WeatherPortlet/ajax/json]
      DEBUG [http-8443-6] annotation.DefaultAnnotationHandlerMapping.[] Sep/18 09:28:27 - Mapping [/json] to handler 'org.jasig.portlet.weather.servlet.AjaxResponseController@1e74bb4'
      DEBUG [http-8443-6] servlet.DispatcherServlet.[] Sep/18 09:28:27 - Last-Modified value for [/WeatherPortlet/ajax/json] is: -1
      DEBUG [http-8443-6] servlet.DispatcherServlet.[] Sep/18 09:28:27 - DispatcherServlet with name 'AjaxServlet' processing request for [/WeatherPortlet/ajax/json]
      DEBUG [http-8443-6] support.HandlerMethodInvoker.[] Sep/18 09:28:27 - Invoking request handler method: public org.springframework.web.servlet.ModelAndView org.jasig.portlet.weather.servlet.AjaxResponseController.renderAjaxResponse(javax.servlet.http.HttpServletRequest,javax.servlet.http.HttpServletResponse) throws org.springframework.web.bind.ServletRequestBindingException,java.io.IOException
      DEBUG [http-8443-6] util.DefaultModelPasser.[] Sep/18 09:28:27 - Found model '

      {status=success}

      ' in HttpSession for key 'ij3qn0waDSweka0+BesDAHRyXvBSHlnGExLcXpvE'
      DEBUG [http-8443-6] support.DefaultListableBeanFactory.[] Sep/18 09:28:27 - Returning cached instance of singleton bean 'jsonView'
      DEBUG [http-8443-6] servlet.DispatcherServlet.[] Sep/18 09:28:27 - Rendering view [net.sf.json.spring.web.servlet.view.JsonView: name 'jsonView'] in DispatcherServlet with name 'AjaxServlet'
      DEBUG [http-8443-6] servlet.DispatcherServlet.[] Sep/18 09:28:27 - Successfully completed request

      Both logs have this:
      DEBUG [http-8443-4] servlet.DispatcherServlet.[] Sep/18 08:56:33 - Servlet 'AjaxServlet' configured successfully

      Similar behaviors of not refreshing after modifying occur when adding locations.

      In both environments, all I did was change the WeatherPortlet version number from 1.0.7 to 1.0.9 in the uPortal Parent pom.xml, ran “ant clean”, “ant clean-tomcat” and “ant deploy-ear”.

        Activity

        Paul Gazda added a comment -

        I have determined that this problem is caused by the interaction with our Cisco ACE load balancer. The ACE handles our Linux environments, but not my PC. When I use the WeatherPortlet in out Linux environment without the ACE, it works correctly. This issue can be canceled.

        Drew Wills added a comment -

        Not an issue per reporter's comment


          People

          • Assignee:
            Unassigned
            Reporter:
            Paul Gazda
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: