uPortal
  1. uPortal
  2. UP-2377

User locale isn't passed to theme stylesheet

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 3.0.0-M5, 3.0.0-RC2, 3.0.0-RC3, 3.0.0, 3.0.1, 3.1.0-M1, 3.0.2, 3.0.3-RC1, 3.1.0-M2, 3.1.0-RC1, 3.0.3, 3.1.0-RC2
    • Fix Version/s: 3.0.4, 3.1.1, 3.2.0-RC1
    • Component/s: Internationalization
    • Labels:
      None

      Description

      universality.xsl parameter USER_LANG is never specified through transformer therefore default locale (en) is always used.

        Activity

        Hide
        Eric Dalquist added a comment -

        There is more work figuring this out and how the xpath lang() function works than can be done before 3.1.0. I added example code to StaticRenderingPipeline for getting the user's preferred locale but this won't get fixed until 3.1.1/3.0.4

        Show
        Eric Dalquist added a comment - There is more work figuring this out and how the xpath lang() function works than can be done before 3.1.0. I added example code to StaticRenderingPipeline for getting the user's preferred locale but this won't get fixed until 3.1.1/3.0.4
        Hide
        Eric Dalquist added a comment -

        Fixed in trunk (45858) and 3.1-patches (45859)

        Show
        Eric Dalquist added a comment - Fixed in trunk (45858) and 3.1-patches (45859)
        Hide
        Eric Dalquist added a comment -

        Also fixed in 3.0-patches (45862)

        Show
        Eric Dalquist added a comment - Also fixed in 3.0-patches (45862)

          People

          • Assignee:
            Eric Dalquist
            Reporter:
            Arv��ds Grabovskis
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: