uPortal
  1. uPortal
  2. UP-2359

StaticRenderingPipelin throws Null pointer exception when trying to log error

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 3.0.3, 3.1.0-RC2
    • Fix Version/s: 3.1.0, 3.0.4
    • Component/s: Rendering architecture
    • Labels:
      None

      Description

      ERROR [TP-Processor3] portal.ExceptionHelper.[] Mar/13 08:38:36 - Programming error
      org.jasig.portal.PortalException: java.lang.NullPointerException
      at org.jasig.portal.rendering.StaticRenderingPipeline.renderState(StaticRenderingPipeline.java:682)
      at org.jasig.portal.PortalSessionManager.doGetInternal(PortalSessionManager.java:248)
      at org.jasig.portal.PortalSessionManager.doGet(PortalSessionManager.java:177)
      Caused by: java.lang.NullPointerException
      at org.jasig.portal.rendering.StaticRenderingPipeline.renderState(StaticRenderingPipeline.java:412)
      ... 23 more

      Caused by the PortalException has a null cause. Fixed by changing StaticRenderingPipeline line 412
      from
      log.error("UserInstance::renderState() : ...+e.getCause().toString());
      to
      log.error("UserInstance::renderState() : ...+e.toString());

        Issue Links

          Activity

          Eric Dalquist added a comment -

          Fixed in trunk, 3.1-patches and 3.0-patches. Changed the log.error statement so it passes the root exception e in as a direct argument to the logger so it is correctly logged.


            People

            • Assignee:
              Eric Dalquist
              Reporter:
              Susan Bramhall
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: