Student Success Plan
  1. Student Success Plan
  2. SSP-1827

Load Template dialog does not reflect recent changes

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: SSP 2.1.0, SSP 2.0.1
    • Fix Version/s: SSP 2.1.0, SSP 2.0.1, SSP 2.2.0
    • Component/s: MAP
    • Labels:

      Description

      Observed in the field (2.0.1) and reproduced locally (2.0.1) and on Linux CI (2.1.0).

      1) Edit any Template to change any field that is displayed in the Load Template dialog's grid view (activeness, privateness, name, advisor)
      2) Click "Load Template" again
      3) Row representing the edited template will not reflect changes. (Or, if authorship changed, the row representing the new Template will not be present.)

      The database will have been updated correctly, though.

      Affects all creation scenarios, not just the clone-on-authorship-change case.

      Basically, just seems that the dialog caches its contents until you navigate away from the tool and come back. Data isn't actually being corrupted nor incorrectly stored, but it's very disconcerting to an end user because it looks like the changes didn't take, especially for the fields we don't display elsewhere (activeness, privateness, adivsor).

        Activity

        Dan McCallum added a comment -

        This is fixed in rel-2-0-patches for 2.0.1. The Template store will reload whenever the Template chooser dialog is shown.

        I'm leaving the merge-to-2-0 label on because that's what everyone is actually using currently to track work on 2.0.1.

        Still needs to be merged to master, hence the merge-to-2-1 label.

        Dan McCallum added a comment -

        Cherry-picked into rel-2-1-patches for 2.1.0. Still needs to be cherry-picked into master (2.2.0). Leaving both merge labels attached pending QA.

        Dan McCallum added a comment -

        Cherry-picked into master for 2.2.0. Leaving merge-to-2-2 label attached pending QA.


          People

          • Assignee:
            Dan McCallum
            Reporter:
            Dan McCallum
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: